Логические функции

В этой статье мы рассказали о работе с логическими функциями в Excel:

Функция ЕСЛИ

Функция ЕСЛИ проверяет, выполняется ли заданное условие и в зависимости от этого выдает результат.

Формула: если(лог_выражение;[значение_если_истина];[значение_если_ложь])

лог_выражение — выражение, которое проверяет функция;

значение_если_истина — значение, которое покажет функция, если выражение правдиво. Необязательный элемент. Если его не указать, автоматически примет значение ИСТИНА;

значение_если_ложь — значение, которое покажет функция, если выражение ложно. Необязательный элемент. Если его не указать, автоматически примет значение ЛОЖЬ.

Пример:

Проверим, верно ли, что ячейка B1 больше ячейки C1. Формулу запишем в ячейке A1:

=ЕСЛИ(B1>C1;»Все верно»;»Не верно»)

Получаем следующий результат:

sreda31_esli1_excel2016
sreda31_esli2_excel2016

Функция И

Функция И проверяет, все ли аргументы являются истинными и возвращает значение ИСТИНА (если да) и ЛОЖЬ (если нет).

Формула: и(логическое_значение_1;логическое_значение_2…)

Количество аргументов может быть от 1 до 255.

Пример: проверим, существуют ли оба значения в столбцах B и C.

Функция И
Функция И

Функция ИЛИ

Функция ИЛИ проверяет, является ли хотя бы один аргумент истинным и возвращает значение ИСТИНА (если да) и ЛОЖЬ (если нет).

Формула: или(логическое_значение_1;логическое_значение_2…)

Количество аргументов может быть от 1 до 255.

Пример: проверим, существуют ли хотя бы какие-то значения в столбцах B и C.

Функция ИЛИ
Функция ИЛИ

Функции ЕСЛИМН и ПЕРЕКЛЮЧ

В этом видео-уроке мы рассказали о новых логических функциях в Excel 2019: ЕСЛИМН и ПЕРЕКЛЮЧ.

Другие уроки по Excel.

Поделиться:

Читайте также: